Contact forms
Incident Report for Dixa
Postmortem

Summary:

Between 00:00 to 13:45 CET on 08/07/2022, we detected unintended behaviour in the Contact Forms channel for some of our customers.

The contact forms generated via webform endpoints were overriding the information from the end-user and replacing it with the "To" email, creating a loop in the conversations.

Our support team triggered the incident management process following the client's reports.

Our incident manager involved the relevant engineering teams and management at 10:57hs, and an active investigation began.

After further examination, we deployed a fix at 12:37hs, after which we started to see other improvements.

We continued to monitor until full recovery and system stability were confirmed.

Timeline (all times are in CEST):

00:00 We've become aware of a potential issue with Contact Forms and initiated our investigation.

03:15 We notified the engineering team.

09:00 We got new reports from different customers.

11:08 We reported on Status Page.

12:14 The issue was identified.

12:37 A fix was implemented by our team. We started to see improvements in the services.

13:06 Monitoring phase. The system was operating normally.

13:47 Case was resolved.

Posted Jul 21, 2022 - 11:29 CEST

Resolved
All known issues to this incident have been resolved. We thank you for your patience and cooperation.

Post mortem about this incident will be posted within 5 business days.
Posted Jul 08, 2022 - 13:47 CEST
Monitoring
We are happy to inform you that our teams have deployed a fix for the issue. We are seeing significant improvements in Contact Forms. We will continue to monitor the results.

Next update at 13:30hs
Posted Jul 08, 2022 - 13:06 CEST
Update
We continue the investigation, trying to find the root cause and estimating the scope of it. 
We appreciate your patience.

Next update: 13hs
Posted Jul 08, 2022 - 12:21 CEST
Update
We are continuing to investigate this issue.
Posted Jul 08, 2022 - 11:09 CEST
Investigating
We are experiencing some difficulties with Contact Forms. We are investigating the matter.

Next update at 11:30hs
Posted Jul 08, 2022 - 11:08 CEST
This incident affected: Email (Outbound).