Degraded performance: Analytics and Dashboard
Incident Report for Dixa
Postmortem

Summary:

On November 5th, 2024, between 07:59 AM and 13:58 PM CET, we experienced lagging data ingestion, impacting the Real-time Dashboard and Analytics Dashboard.

By 10:42 AM CET, a fix was successfully implemented, leading to improvements across all affected Dashboards.
We entered a phase in which data ingestion was catching up.
By 1:58 PM dashboards were fully restored.

To prevent future occurrences, we are enhancing our internal systems, particularly focusing on improving automatic alerts for quicker issue detection and response.

Timeline (CET):

  • 07:59 AM: The Engineering team identified Analytics lagging and started the investigation proactively. Status page updated
  • 10:42 AM: Root cause confirmed and a fix implemented. Data ingestion was catching up
  • 1:58 PM: Full functionality restored.

As always, we appreciate your patience and collaboration during this process.

Posted Nov 11, 2024 - 14:04 CET

Resolved
This incident has been resolved. We thank you for your patience and cooperation.
Posted Nov 05, 2024 - 13:58 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 05, 2024 - 10:42 CET
Update
We are continuing to investigate this issue.
Posted Nov 05, 2024 - 08:53 CET
Update
We are continuing to investigate this issue.
Posted Nov 05, 2024 - 08:02 CET
Investigating
We are experiencing some difficulties with Analytics. We are investigating the matter.

Next update at 07:30 UTC
Posted Nov 05, 2024 - 07:59 CET
This incident affected: Agent Interface (Analytics, Dashboard).