DNS Configuration Issue Impacting API Connectivity

Incident Report for Dixa

Postmortem

Date: August 26, 2025
Duration: 25 minutes (14:20 - 14:45 CEST)
Severity: High - Complete API unavailability

Summary

A DNS configuration error during staging environment setup caused a complete outage of our public API at dev.dixa.io for 25 minutes. All external integrations and services dependent on our API were affected.

Timeline

  • 14:20 CEST - DNS records for dev.dixa.io inadvertently deleted during staging setup
  • 14:20 CEST - API connectivity issues began affecting all external services
  • 14:45 CEST - DNS configuration restored, services resumed normal operation

Root Cause

During the setup of staging DNS entries for euw1.dev.dixa.io, the existing DNS records for dev.dixa.io were accidentally removed instead of being preserved alongside the new staging records. This caused all DNS queries for dev.dixa.io to return NXDOMAIN responses.

Impact

  • Duration: 25 minutes of complete API unavailability
  • Affected Services: All external integrations including native integrations, custom cards, flow automations, Zapier, chatbots, and third-party API consumers
  • User Impact: Complete inability to access API-dependent functionality

Resolution

The DNS configuration was corrected by restoring the proper DNS records for dev.dixa.io, immediately resolving the connectivity issues.

Posted Aug 26, 2025 - 15:29 CEST

Resolved

DNS records for dev.dixa.io were inadvertently removed. This resulted in DNS resolution failures when attempting to connect to dev.dixa.io, as requests received "NXDOMAIN" responses indicating no available IP address.
This issue affected all services and integrations relying on our public API, including:

Native integrations
Custom cards
Integration nodes in flows and automations
Third-party services (Zapier, chatbots, etc.)
All external API connections

All affected services experienced connection failures during this period. The issue was resolved by restoring the proper DNS configuration for dev.dixa.io.
Posted Aug 26, 2025 - 14:20 CEST