Degraded performance - Translations not working

Incident Report for Dixa

Postmortem

Summary

Dixa experienced partial degraded performance of AI-Co pilot features on October 14 2025 between 08:13-13:13 CEST. Users who never changed their translation settings were affected, experiencing unwanted auto-translations and non working translations. The issues were cause by an increased number of translation requests hitting our api, leading to overload. We eventually solved it by increasing the capacity for handing requests and by reverting the changes

Timeline

At 08:13 am CEST A change was deployed for AI copilot to default the Auto summary and translations to “Automatic” for users who never changed their preferences

At 09:48 am CEST First reports of difficulties with translations for AI Co-pilot that didn’t work at all.

At 10:23 am CEST A fix is deployed to support the increased amount of requests incoming.

At 10:33 am CEST Fix is evaluated to have mitigated the issues.

At 11:33 CEST The requests to our API increase and issues come back, more reports are coming in from customers about conversations being automatically translated or translations not working at all.

At ~12:45 am CEST Fix is applied to support even more increased amount of requests to prevent translation failures and the quota on the model used by translation is increased to support the increased amount of requests.

At 13:13 am CEST A final fix is deployed - changes to AI copilot settings defaults are reverted and requires agents to reload to take effect. This decreased the system overload.

Impact

The incident had a major impact on the users of the AI Co-pilot feature that never changed their settings who experienced degraded performance with conversations not translating or unwanted increased amount of translations performed.

Root cause

The frontend changes to settings defaults for AI auto summary and translate flipped the settings from on-demand to automatic. It was applied to existing customers that never changed their settings. It appeared to be a significant amount of customers who had not done any changes to their settings. The change took effect over the course of multiple hours, because it required agents to reload the UI for the settings to take effect. This caused many more translations being performed where customers did not expect. Additionally, this caused increased amount of translation requests via rest-api, which made rest-api incapable of performing all requests due to it having a capped number on max open requests

Resolution

  • Support for and quota of translation requests were increased
  • The frontend change to settings defaults for AI Co-pilot were reverted

We have taken steps to improve our processes for control and increased the capacity limit so that this won’t happen again.

We apologize for the inconvenience this caused and thank you for you cooperation

Posted Oct 17, 2025 - 16:18 CEST

Resolved

All known issues to this incident have been resolved. We thank you for your patience and cooperation.

Post mortem about this incident will be posted within 5 business days.
Posted Oct 14, 2025 - 14:41 CEST

Monitoring

A new fix has been deployed and we're seeing improvements. Please refresh the website and it should be back to normal. We're monitoring the progress
Posted Oct 14, 2025 - 12:54 CEST

Update

We're still experiencing instabilities relating to AI Co-pilot features and we're working on a fix for it
Posted Oct 14, 2025 - 12:25 CEST

Identified

Our teams has now identified the issue and have deployed a fix. We're seeing progress and are monitoring.
Posted Oct 14, 2025 - 10:37 CEST

Investigating

We are experiencing some difficulties with translations for AI Co-pilot. We are investigating the matter.
Posted Oct 14, 2025 - 10:24 CEST
This incident affected: AI Features (AI Copilot).