Degraded performance
Incident Report for Dixa
Postmortem

At 09:31 UTC on November 18th of 2022, we were notified that the agent status did not switch to away if a conversation offer timed out

Our engineers immediately started working on identifying the root cause.

At 10:07 UTC, our engineers identified the issue to be related to a disconnected service that was not in synch with the underlining offer logic.

At 10:17 UTC, the incident was resolved by restarting the service. We have performed a Root Cause Analysis of this incident and are implementing solutions in order to prevent such instances from happening in the future.

We sincerely apologize for any inconvenience that this may have caused.

Posted Dec 16, 2022 - 13:20 CET

Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 11:24 CET
Identified
We have implemented a fix and the offers are back to normal. We're monitoring now
Posted Nov 18, 2022 - 11:20 CET
Update
Update: After further investigation, we have found that a conversation that was timed out will not be offered to the next available agent. As a workaround, the agent for which the conversation offer was timed out should toggle themselves away and online again.

We have identified the issue and we're working of a fix
Posted Nov 18, 2022 - 11:13 CET
Update
We're currently experiencing an issue with conversation offers. An agent who does not accept a conversation offer does not change status to "away".
Posted Nov 18, 2022 - 10:44 CET
Investigating
We have received reports of instability in the platform. We are investigating the issue. Updates will follow
Posted Nov 18, 2022 - 10:31 CET
This incident affected: Agent Interface (Conversation Offers (WSS connection)).