Degraded performance: AiCoPilot: Smart replies

Incident Report for Dixa

Postmortem

Dixa experienced issues with the Smart Reply feature in AI CoPilot on 18 March 2026.

Summary
18 March 2026 at 14:37 CET - 20:20 CET, customers experienced issues with the Smart Reply feature in AI CoPilot. Agents were unable to use Smart Reply.

Root cause
A code change introduced a regression that caused agents' browsers to block completing the request to load Smart Reply suggestions.

Timeline
At 14:37 CET on 18 March 2026: Issue flagged internally after several customers reported the issue
At 15:33 CET: Engineering investigates and attempts an initial rollback, which does not resolve the issue.
At 16:02 CET: Status page updated to "Investigating" — customers notified of difficulties with AiCoPilot Smart Replies.
At 16:48 CET: Status page updated — engineering continues to investigate.
At 18:17 CET: Status page updated — root cause investigation ongoing
At 20:20 CET: The knowledge-backend service is successfully rolled back to a stable version, restoring Smart Reply.
At 20:52 CET: Status page updated to "Resolved" — all known issues confirmed resolved.

Solution
The immediate solution was to roll back to a stable version from prior to the breaking change, restoring Smart Reply for all affected customers.
Long term, the team will review the offending commit before re-deploying to prevent similar regressions from reaching production undetected.
We sincerely apologise for the inconvenience caused by this issue.

Posted Mar 26, 2026 - 09:57 CET

Resolved

All known issues to this incident have been resolved. We thank you for your patience and cooperation.

Post mortem about this incident will be posted within 5 business days.
Posted Mar 18, 2026 - 20:52 CET

Update

Our engineering team is actively investigating the root cause.
This might take some time to fully resolve and we will continue to provide updates here on daily basis.
We apologize for any inconvenience caused and thank you for your patience.
Posted Mar 18, 2026 - 18:17 CET

Update

We are further investigating the matter.
Thank you for your patience.
Posted Mar 18, 2026 - 16:48 CET

Update

We are continuing to investigate this issue.
Posted Mar 18, 2026 - 16:02 CET

Investigating

We are experiencing some difficulties with the AiCoPilot feature "Smart Replies". We are investigating the matter.

Next update at 3:30 PM UTC
Posted Mar 18, 2026 - 16:02 CET
This incident affected: AI Features (Smart Replies).