Some phone numbers are currently not working
Incident Report for Dixa
Postmortem

Due to human error, phone numbers located at one of our carriers were incorrectly re-assigned to an inactive Dixa account. Because of this, calls were routed nowhere and inbound calls were failing.

We’ve identified the action taken by the employee and have added measures to prevent this from happening in the future. This is part of an at the time of the incident already ongoing process to modernize internal tools and prevent human data entry errors.

Posted Jun 08, 2021 - 13:35 CEST

Resolved
This incident has been resolved.

Please reach out to friends@dixa.com if you still experience issues.
Posted May 27, 2021 - 11:47 CEST
Monitoring
A fix has been implemented and we're monitoring results.

For admins, phone numbers should be visible again in your account under Settings -> Phone. If this is not the case, please reach out to support.
Posted May 27, 2021 - 11:16 CEST
Identified
The issue has been identified and we are restoring service.

Next update at 11:30 CEST
Posted May 27, 2021 - 11:05 CEST
Update
We are continuing to investigate this issue.
Posted May 27, 2021 - 10:52 CEST
Investigating
We are experiencing some difficulties with inbound telephony for some phone numbers. We are investigating the matter.

Next update at 11:20 CEST
Posted May 27, 2021 - 10:50 CEST
This incident affected: Telephony (Inbound, Outbound).