Partially degraded performance of Agent Interface
Incident Report for Dixa
Postmortem

On Monday, 7th of June 2021 at 21:52 CEST Dixa was automatically informed by a monitoring tool of a large number of reconnections.

A few minutes later, at 21:55 CEST reports came in from Dixa customers about the platform not being reachable.

After a brief investigation, we concluded that the affected services didn't scale up and we decided to redeploy the application at 22:11 CEST as to trigger the automatic scaling again.

At 22:14 CEST, we received confirmation that all services were working again as expected. Investigation did not bring the root cause of the reconnections but did bring to light why the services didn't scale up to handle the increased reconnection count.

Steps were taken to prevent this from happening in the future. We apologize for any inconvenience this may have caused.

Posted Jun 22, 2021 - 15:46 CEST

Resolved
We've monitored the relevant services and no longer see abnormal behaviour. We're therefore confident the issue has been resolved.

In case you still have issues, please reach out to friends@dixa.com.
Posted Jun 07, 2021 - 22:35 CEST
Monitoring
We've identified the cause and deployed a fix. We're seeing normalized platform performance now and are monitoring.
Posted Jun 07, 2021 - 22:18 CEST
Investigating
Some slowness and unresponsiveness in the Agent Interface. We are investigating the issue.
Posted Jun 07, 2021 - 22:11 CEST
This incident affected: Agent Interface.