Degraded performance

Incident Report for Dixa

Postmortem

Summary: On March 10, 2026, all public Dixa Knowledge Help Centers were unavailable following a production deployment performed during scheduled maintenance.

Impact

  • Dixa Knowledge Public Help Centers remained inaccessible for 6 hours (approximately)
  • Customers with advanced custom CSS styling were contacted directly with instructions on how to update their selectors to prevent recurrence.

Root Cause: After the production deployment performed during a scheduled maintenance, all public Help Centers became unavailable. Visitors saw an error page (500) instead of help content.

Timeline (CET)

Mar 10, 08:00 - Maintenance completed. No anomalies detected.

Mar 10, 11:52 - Initial customer reports received. Considered isolated cases at the time.

Mar 10, 13:38 - Incident process triggered. Reported on Status page.

Mar 10, 13:57 - Root cause fully identified.

Mar 10, 14:13 - Fix deployed. Public Help Centers restored; some styling issues persisted.

Mar 10, 14:48 - Root cause for styling anomalies identified as linked to build-time generated class names. Affected customers notified with instructions.

Mar 10, 18:03 - Incident resolved.

Resolution: We identified a misconfiguration in the deployment that caused Help Centers to attempt to load from a test environment rather than production. A fix was deployed, and an immediate reduction in error rates confirmed it was effective.

What We Have Done Since This Incident: Following this incident, we have already implemented the following improvements:

  1. Proactively contacted all affected customers with clear instructions on how to update their custom CSS styling.
  2. Documented additional validations for future migrations and action plans to address similar errors.
  3. External documentation updated to offer alternatives to the use of auto-generated classes for styling Help Centers.

What We're Continuing to Work On

  • Improve monitoring and alerting, ensure availability issues are detected and escalated promptly, independent of customer reports.
  • Investigating a solution to expose stable, named elements for Help Center customization, reducing dependency on build-generated class names.

Closing Note: We sincerely apologize for the disruption this caused. We appreciate your patience throughout this disruption. If you have any questions, please reach out to friends@dixa.com.

Posted Mar 16, 2026 - 18:04 CET

Resolved

We can confirm that the issue has been resolved.
A postmortem report will be published within 5 business days.
Posted Mar 10, 2026 - 18:03 CET

Update

We are continuing to monitor the situation. While the Help Center (Dixa Knowledge) has largely recovered, some custom CSS styling issues remain. We will provide a further update shortly
Posted Mar 10, 2026 - 14:48 CET

Monitoring

A fix has been deployed and we are seeing significant improvements to the Help Center (Dixa Knowledge).
Some images and custom styling may still not display correctly yet. Our team is actively working to resolve this.

Next update: 14:30 CET.
Posted Mar 10, 2026 - 14:13 CET

Identified

Our teams has now identified the issue. We are working on a fix, that will resolve the issue.
We will provide more information soon.

Next update at 14:10 CET
Posted Mar 10, 2026 - 13:57 CET

Investigating

We are currently investigating an issue affecting the Help Center (Dixa Knowledge).

We will provide a further update by 14:00 CET.
Posted Mar 10, 2026 - 13:38 CET
This incident affected: Dixa Knowledge (Knowledge Bases).