Degraded performance
Incident Report for Dixa
Postmortem

Summary:

Between 14:52 and 15:24 CEST on August 17, 2023, Dixa had intermittent performance degradation.

With the initial reports from agents, we began to monitor the system and noticed fluctuations in the services that were primarily perceived as slowness. At 15:07, Dixa became unresponsive and the Incident process was triggered.

Our incident manager involved the relevant engineering teams, and an active investigation began.

Our engineers identified the root cause as a suboptimal workload combined with high continuous system usage, which overloaded one of our subsystems.

At 15:17, we deployed a fix and started to see improvements in all services.

We continued actively monitoring until complete recovery.

At 15:24, the incident was resolved.

Timeline (all timestamps in CEST):

14:52 We got the first reports from agents and we started monitoring the issue.

15:07 Dixa beca,e unresponsive.

15:10 We triggered the incident process. The issue was reported on the status page and the engineering team started an investigation.

15:15 Issue identified

15:17 Fix Deployed successfully.

15:18 Moved into Monitoring phase

15:24 Resolved

Posted Aug 25, 2023 - 23:43 CEST

Resolved
This incident has been resolved.
Posted Aug 17, 2023 - 15:48 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2023 - 15:36 CEST
Update
We are continuing to investigate this issue.
Posted Aug 17, 2023 - 15:17 CEST
Update
We are continuing to investigate this issue.
Posted Aug 17, 2023 - 15:14 CEST
Investigating
We have received reports of instability in the platform. We are investigating the issue. Updates will follow
Posted Aug 17, 2023 - 15:10 CEST
This incident affected: Agent Interface (Agent Interface).