Intermittent issues with AI features

Incident Report for Dixa

Postmortem

Summary

On the 16th of December 2025 between 8:49 PM CET and 9:34 PM CET we experienced intermittent issues with AI features such as Co-pilot and intent detection automation on some of the Dixa instances.

Root cause

The incident was caused by the increased usage of the above mentioned features which caused hitting the set usage limit.

Timeline

At 8:49 PM CET: We started observing usage spikes which resulted in errors that started occurring around AI related features.

At 8:55 PM CET: Status page was updated with the areas that were impacted by the issue.

At 9:03 PM CET: We found the root cause and moved the incident status to Identified.

At 9:12 PM CET: The fix was deployed and the incident status changed to Monitoring.

At 9:34 PM CET: After a period of monitoring we did not observed any more errors and the incident status was moved to Resolved.

Solution

The immediate solution was to increase the usage limits as well as implement the separation of the limits per each AI feature in the backend.

Long term we are planning to implement proactive alerting and monitoring around AI features usage and set limits to prevent the errors that occurred when the usage spiked. ‌

We sincerely apologise for the inconvenience caused by the above issue.

Posted Dec 23, 2025 - 17:51 CET

Resolved

This incident has been resolved. We will publish postmortem within 5 business days.
Posted Dec 16, 2025 - 21:34 CET

Monitoring

We deployed a fix and can see that the issue is resolved. We will monitor the situation for a some time now until we fully close the incident.
Posted Dec 16, 2025 - 21:12 CET

Identified

We have identified the root cause and applying the fix.
Posted Dec 16, 2025 - 21:03 CET

Update

We are continuing to investigate this issue.
Posted Dec 16, 2025 - 20:55 CET

Investigating

We are observing challenges with loading Co-pilot features. We are working on identifying the root case and will update the status page as soon as the issue is identified.
Posted Dec 16, 2025 - 20:49 CET
This incident affected: AI Features (AI Copilot).