Telephony - Some calls are not connecting
Incident Report for Dixa
Postmortem

On Tuesday morning 12th September, we received reports of issues related to telephony. After some initial investigations, we noticed that calls were not connecting to Dixa on certain numbers predominantly in the Nordic region. Calls logs showed multiple failed attempts to connect and customers were unable to get in touch with an agent.

The issues were related to a failure in a subprocesses for one of our upstreams suppliers on which these numbers were hosted. This prevented us from receiving a response when sending an invite to connect the calls with Dixa.

Only a subset of numbers with our operator were affected by this incident. We would like to thank you for your cooperation and apologize for any inconvenience this caused. We are working with our supplier to prevent future similar outages in the future 

Timeline (CEST)

September 12th, 8:10 AM CEST - We received the first report on issues relating to telephony

September 12th, 9:13 AM CEST - The issues were identified to be related to a subset of number related to one of our service providers. We’re working with them to find the root-cause

September 12th, 10:00 AM CEST - Root-cause was identified and a fix was being worked on. Statuspage updated.

September 12th, 10:36 AM CEST - A fix was finalized and released which brought the numbers back online. Status is set to Monitoring

September 12th, 12:26 AM CEST - After monitoring for a while and confirming with the affected customers, the issue was marked as resolved and the status page updated.

Posted Sep 18, 2023 - 11:10 CEST

Resolved
The issues to this incident have been resolved and no further issues have been detected while monitoring. We thank you for your patience and cooperation.

Post mortem about this incident will be posted within 5 business days.
Posted Sep 12, 2023 - 12:26 CEST
Monitoring
We are happy to inform that a fix has been deployed for the issue and the numbers are now working. We will continue to monitor the results.

Next update: latest 12:00 CEST
Posted Sep 12, 2023 - 10:43 CEST
Update
We're still working with our provider to implement a fix that will resolve the issue.

Next update at 11:00 CEST
Posted Sep 12, 2023 - 10:31 CEST
Identified
We have identified the issue and are working together with our provider to implement a fix. We will keep you updated on any progress.

Next update latest at 10:30 CEST
Posted Sep 12, 2023 - 10:04 CEST
Update
We're still investigating the issue and are in contact with our suppliers to find the root cause.

We will update as soon as we have more information and latest at 10:20 CEST
Posted Sep 12, 2023 - 09:52 CEST
Update
We are experiencing some difficulties with the telephony channel related to one of our suppliers. We are investigating the matter.

Next update at 09:50 CEST
Posted Sep 12, 2023 - 09:21 CEST
Investigating
We have received reports of instability in the platform. We are investigating the issue. Updates will follow
Posted Sep 12, 2023 - 09:07 CEST
This incident affected: Telephony & SMS (Inbound).