Advanced Insight & Miuros: Degraded performance

Incident Report for Dixa

Resolved

All known issues with this incident have been resolved. We thank you for your patience and cooperation.
Posted Jul 28, 2026 - 13:15 CEST

Investigating

We are experiencing some difficulties with Advanced Insight & Miuros. We are investigating the matter.

Next update at 13:30 CEST
Posted Jul 28, 2026 - 12:47 CEST
This incident affected: Intelligence (Insights (advanced)).